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Chapter 1: Installing the documentation 

software

Downloading the software

Procedure

1. Connect to the Avaya network.

2. Open the Share Point location, https://avaya365.sharepoint.com/:f:/r/

sites/ProductsInformation_Solutions/GIS_DITA_AuthoringTools/

Shared%20Documents/RWS-FormerlySDL/TridionDocs-Installation/

SDLClientTools-ArbortextEditor71.

3. Download the following files to your local drive:

a. Oxygen XML Author 21.1, oxygenAuthor-64bit.exe

b. SDL Publication Manager, <date>.PublicationManager.<num>.msi

c. SDL Publication Manager, <date>.AuthoringBridge.<num>-oXygen-

Connector.msi

Next steps

Install the software in the given sequence.

Installation sequence

Install the software in the following order:

• SDL Publication Manager

• Oxygen XML Author

• SDL Oxygen Connector
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Installing the SDL Tridion Docs Publication Manager

About this task

SDL Tridion Docs client tools include Publishing Manager and Authoring Bridge.

Procedure

1. Install Publication Manager, the .msi file and follow the prompts, accepting all defaults.

2. Click Install.

3. Click Finish.

Next steps

Install Oxygen XML Author.

Installing Oxygen XML Author

About this task

You need Oxygen XML Author to add and edit DITA files in SDl Tridion Docs.

Before you begin

• Ensure you install SDL Publication Manager.

• Download the Oxygen XML Author executable file to your computer.

• Connect to the Avaya network.

Note:
If you are not connected to the Avaya network, registration to Oxygen licensing server 

fails.

• Close MS Outlook and any other editor, such as MS Word and Notepad.

Procedure

1. Run oxygenAuthor-64bit.exe to install the application.

Oxygen XML Author software is now available on your computer.

2. Start Oxygen XML Author.

3. If Oxygen XML Author prompts, in the Oxygen license dialog box, click Use a license 

server.

Note:

If Oxygen XML Author does not prompt you to set up a license, from the menu, click 

Help > Register and click Use a license server.

Installing the SDL Tridion Docs Publication Manager
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4. In HTTP/HTTPS server, complete the following:

• URL: http://135.8.44.166/license-servlet

• User: Your Avaya handle. For, example, sharma123

• Password: your Avaya handle. For, example, sharma123

5. Click OK.

6. (Optional) When Oxygen XML Author prompts:

• “Switching to license server will clear the stored named license key details”, click Yes.

• “The host is not in the list of trusted host. Do you want to allow?”, click Allow and 

Remember.

7. (Optional) If the editor prompts you to authenticate, in the Authorization window, provide 

your username and password that you set in Step 4.

8. Restart Oxygen XML Author.

Next steps

Install SDL Authoring Bridge for Oxygen XML Author.

Related links

Setting Oxygen XML Author as the default XML editor on page 10

Setting tag view and space marks in Oxygen XML Author on page 11

Additional Oxygen XML Author configuration on page 11

Installing the authoring bridge for Oxygen XML Author

About this task

You need to install Authoring Bridge to access SDL repository and update DITA topics and maps 

from Oxygen XML Author.

Before you begin

• If you use non-Avaya computer, ensure the following:

- Log in as admin and install the authoring bridge.

Skipping this step may result in installation issues.

- Avaya IT team installs Avaya third-party certificates on your computer.

• Ensure you install Oxygen XML Author.

Procedure

1. Install Authoring Bridge for Oxygen XML Author, the .msi file.

2. Click Next.

Installing the documentation software
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3. When the installer prompts, click Finish.

4. To verify if the installation of Authoring Bridge is successful, open Oxygen XML Author and 

look for the SDL Tridion Docs menu.



Next steps

Add repository and your account in SDL Tridion Docs.

Adding repository and SDL account in Tridion Docs

About this task

To access Tridion Docs repository, add your unique user account information in SDL Tridion Docs 

Publication Manager.

Note:
SDL is the older name for RWS.

Before you begin

• Install Tridion Docs Publication Manager and Authoring Bridge.

• Request Information Architect to create your SDL account user name and password and 

keep the credentials handy.

Procedure

1. From Windows Start, click SDL Tridion Docs > Publication Manager 14.0 to launch 

Publication Manager.

2. Click Tools > Accounts and when the Accounts dialog box opens, click Add.



3. On the Add Account dialog box:

a. In Account name, type a name, for example, KavithaS-Prod.

Note:

Provide an account name that is different from your SDL username.

Adding repository and SDL account in Tridion Docs
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If you must create a separate SDL account on Development and Production servers, 

provide different account names to differentiate the Development and Production 

environments. For example, KavithaS-Prod and KavithaS-Dev.

b. In the Content Manager web service field, type https://

avaya001.sdlproducts.com/ISHWS



c. Click Next.

d. In the Username and Password fields, provide your RWS account username and 

password that you received from Information Architect or the DITA mentor.



4. Select the Remember password check box and click Next.

5. When the validation is complete, click Finish.

Publication Manager synchronizes with the Tridion Docs database. This might take about 

two minutes.

6. When the message displays that the Synchronization is done, click Close.

7. In Publication Manager, on the Accounts dialog box, click Properties, and click Test 

Account.

The system must display Log on to Tridion Docs is successful using the 

account settings.

Installing the documentation software
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8. (Optional) Select the account that points to https://avaya001.sdlproducts.com/

ISHWS and click Set as default.

This step applies only if you have more than one account, for production and development 

environments. When in doubt, check with your lead or IA.

Next steps

When the installation and account setting is complete:

• To open Publication Manager, go to Windows Start, and click SDL Tridion Docs > 

Publication Manager 14.0.

• To access the Tridion Docs web client, go to https://avaya001.sdlproducts.com/

ISHCM and log on using your Tridion Docs credentials.

Adding repository and SDL account in Tridion Docs
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Chapter 2: Additional configuration in 

Oxygen XML Author

Setting Oxygen XML Author as the default XML editor

About this task

To use Oxygen XML Author every time you open a topic, set Oxygen XML Author as the default 

editor.

Before you begin

Install Oxygen XML Author.

Procedure

1. In Publication Manager, select a topic, right-click and check out using the Checkout with 

option.

2. If you do not see the Oxygen XML Author application in the list, browse to the 

C:\Program Files\Oxygen> XML Author 21/oxygenAuthor21.1.exe file, and 

click Open.

Note:

This path might vary depending on the location where the file has been saved during 

the installation.

3. At the bottom-left, click the Windows icon, and type Choose a default app.

4. Select Choose a default app by file type from the list.

5. In the window, scroll down to the .xml file extension and select Oxygen XML Author 21.1 

from the list of applications.

Related links

Setting Oxygen XML Author as default editor video
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Setting tag view and space marks in Oxygen XML Author

About this task

For ease of editing content and setting XML attributes in elements, configure view settings in 

Oxygen XML Author.

Before you begin

• Install Oxygen XML Author.

• Open or check out a topic.

Procedure

1. To set the tag view, do one of the following:

• From the toolbar, click  and select an option.

• Go to DITA > Tags display mode and select an option.

2. To set space marks, do the following:

a. In Oxygen XML Author, click Options > Preferences.

b. In the left pane, click Editor.

c. In the Whitespaces section, select the following check boxes:

• Show TAB/NBSP/EOL/EOF marks

• Show SPACE marks

d. Click Apply and click OK.

3. To add Attributes window:

From the menu, click Windows > Show View  > Attributes.

4. To add Elements window:

From the menu, click Windows > Show View  > Elements.

Additional Oxygen XML Author configuration

You can make additional settings to efficiently use Oxygen XML Author.

Setting tag view and space marks in Oxygen XML Author
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Action/Function Menu in Oxygen
Choose Tag view 1. Options > Preferences > Automatic Spell 

Check

2. Click Editor > Edit Modes > Author

3. From Tags, in Tag display mode, click Full 
Tags.

View Attributes Click Window > Show View > Attributes
Add or modify attributes Attributes window or click Window > Show View > 

Attributes
Add elements or tags Press Enter or click Window > Show View > 

Elements
Enable Spell Checker Options > Preferences > Automatic Spell Check
View Terminology Checker Window > Show View > Terminology Helper

Add conref
Click  from the toolbar or the SDL Tridion 
Docs > Insert conref menu, click the TridionDocs 
icon ( ), and browse to the source topic.

Add xref • Link to topic: Press Enter and select xref (cross 
reference), click the TridionDocs icon ( ), and 
browse to the source topic.

• Link to web source: Press Enter and select xref 
(web link).

Add condition SDL Tridion Docs > Set condition
Remove condition Select the element with condition, in the Attributes 

window, select the ishcondition row, right-click and 
select Remove.

Delete element tag Press Ctrl+Alt+X or click Document > Markup > 
Remove All Markup.

Add image Press Enter and select Image (wizard) or click 
from the toolbar, browse to the image folder, and 
click Insert.

In the wizard, set placement, size, scale and other 
image attributes.

Edit ditamap Using Check out with, select Oxygen XML Author 
and select Editor.

Compare files Document > File > Compare
Find word count Document > Source > Count words
Manage toolbars Window > Configure Toolbars

Example, Spelling, Validation, and Tag display 
mode.

Table continues…

Additional configuration in Oxygen XML Author
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Action/Function Menu in Oxygen
Add space marks 1. Options > Preferences > Editor

2. In Whitespaces section, select the following 
check boxes:

• Show TAB/NBSP/EOL/EOF marks

• Show SPACE marks

Additional Oxygen XML Author configuration
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Chapter 3: Custom Dictionary tools 

installation and configuration

Avaya GIS Authoring environment provides the following tools and customization to help develop 

consistent and comprehensible content.

Terminology Checker

Terminology Checker is a content optimization tool writers use to check content quality. The checker 

measures how well your content complies with the Avaya Customer Documentation Style Guide. It 

provides a report that you can use to improve your content.

The tool runs as a plug-in within Oxygen XML Author.

Custom Dictionary

Custom Dictionary, Avaya's customized dictionary terms for use with Spell Checker.

Autocorrect

This feature automatically and seamlessly corrects words that are frequently misspelled while typing 

in the editor.

Benefits

With this automation:

• Authors have immediate feedback while they develop content, saving rework and reviewing 

iterations.

• Editors can spend less time on common style issues and focus on other content aspects, such 

as comprehensibility, conciseness, clarity, and flow.

• Localization costs reduce due to fewer rework cycles.

• Avaya customers experience more consistent and comprehensible product documentation.

• The team’s efficiency and customer satisfaction improve.
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Terminology Checker installation

Setting the HTTP(S)/WebDAV preferences on Oxygen XML Author

About this task

You must set the network connectivity preferences and install the Terminology Checker plug-in 

only once. When new rules are added, and existing rules are updated, the files are automatically 

copied to your local folder.

Procedure

1. Open Oxygen XML Author.

2. From the menu, click Options > Preferences to open the Preferences dialog box.

3. Click Network Connections Settings > HTTP(S)/WebDAV and select the Automatically 

accept a security certificate, even if invalid check box.



4. Click OK.

Related links

Custom Dictionary tools installation and configuration on page 14

Terminology Checker installation

February 2021 Getting started with Documentation tools 15
Avaya - Proprietary. Use pursuant to the terms of your signed agreement or Avaya policy.

DRAFT—July 24, 2025—7:58 AM (UTC+00:00)

16



Installing the Terminology Checker add-on from Oxygen XML 

Author

Procedure

1. Open Oxygen XML Author, and click Help > Install new add-ons to open an add-on.



2. In Show add-ons from, enter or paste https://www.oxygenxml.com/InstData/

Addons/default/updateSite.xml or select it from the drop-down menu.

3. Select the Terminology Checker add-on and click Next.

4. Read the end-user license agreement, select I accept all terms of the end-user license 

agreement, and click Finish.

5. Restart the application.

On the left pane, the Terminology Helper dialog box lists all errors with suggested words 

and comments.



Custom Dictionary tools installation and configuration
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Related links

Custom Dictionary tools installation and configuration on page 14

Terminology checker and custom dictionaries 

configuration

Specifying the path to rule files in Oxygen XML Author

About this task

You must perform this setting once in Oxygen XML Author. If the rule files are updated in future 

releases, RWS automatically pushes the new rule files to the folder in your system.

Procedure

1. Open Oxygen XML Author.

2. Click Options > Preferences to open the Preferences dialog box.

3. Click Plugins > Terminology Checker.

4. In Additional terminology folder, browse to one of the following folder locations:

• C:\Users\<User-Profile>\Documents\OxygenXMLAuthor\Avaya

• C:\Users\<User-Profile>\OneDrive - 

Avaya\Documents\OxygenXMLAuthor\Avaya

5. Restart Oxygen XML Author.

Related links

Custom Dictionary tools installation and configuration on page 14

Specifying the path to custom dictionaries for Spell Check in 

Oxygen XML Author

About this task

You must perform this setting only once in Oxygen XML Author. When the dictionaries are 

updated later, RWS automatically pushes the new files to the folder in your computer.

Before you begin

In the toolbar, click Spell Checker ( ) or press F7 and ensure the following in the Spelling 

dialog box:

• Clear the Begin at cursor position check box, if already selected.

The Spell Checker begins checking for errors from the beginning of the topic.

Terminology checker and custom dictionaries configuration
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• In the Preference dialog box, click Option, in Editor > Spell Check, select the Automatic 

spell check check box.

Oxygen XML Author highlights errors in the topic.

Procedure

1. Open Oxygen XML Author.

2. Click Options > Preferences to open the Preferences dialog box.

3. Go to Editor > Spell Check > Dictionaries.

4. In the Include dictionaries and term list from option, browse to the following folder 

location:

C:\Users\<User-

Profile>\AppData\Roaming\com.oxygenxml.author\spell\Avaya

Note:

If you do not see the AppData folder in C:\Users\<user-profile>, in the file 

explorer, click View and select the Hidden items check box.

5. Click Apply.

6. Click OK.

7. Restart Oxygen XML Author for the spell checker to start using the new dictionary.

Related links

Custom Dictionary tools installation and configuration on page 14

Specifying the path to custom dictionaries for the AutoCorrect 

feature in Oxygen XML Author

About this task

You must perform this setting once in Oxygen XML Author. If the dictionaries are updated in future 

releases, RWS automatically pushes the new files to the folder in your system.

Procedure

1. Open Oxygen XML Author.

2. Click Options > Preferences to open the Preferences dialog box.

3. Go to Editor > Edit Modes > Author > AutoCorrect > Dictionaries.

4. In the Include dictionaries from option, browse to the following folder location:

C:\Users\<User-

Profile>\AppData\Roaming\com.oxygenxml.author\autocorrect\Avaya

Custom Dictionary tools installation and configuration
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Note:

If you do not see the AppData folder in C:\Users\<user-profile>, in the file 

explorer, click View and select the Hidden items check box.

5. Click Apply.

6. Click OK.

7. Restart Oxygen XML Author for the AutoCorrect feature to start using the new dictionary.

Related links

Custom Dictionary tools installation and configuration on page 14

Terminology checker and custom dictionaries configuration
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Chapter 4: Setting up the development 

environment

Setting up Avaya Documentation Center dev account

About this task

To verify the content that you plan to publish on Avaya Documentation Center, first publish the 

content on the Avaya Documentation Center development site.

With dev account credentials, you can access the development environment.

Procedure

1. Go to https://iam.avaya.com/idmUtil/nonprodidm/menu.jsp.

2. Log in using your Avaya handle and password.

3. To create a new account on the staging environment, click Create User(s) > Associate 

(Internal User) > Attributes.

4. Complete the details that include:

• Userid: Avaya handle. For example, ksamudrala.

Important:

If the user ID is incorrectly set:

- You will not be able to log on to the dev server.

- You cannot update the user ID using Manage Users. You can only remove the 

account.

You need to open a ticket at https://onecare.avaya.com/ to get the account 

removed.

• Mail and Owner Mail: Avaya email ID. For example, ksamudrala@avaya.com.

• Password: Set any password, but NOT your network password.

Your dev account is now created and you will be able to access the Avaya Documentation 

Center dev server.
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5. (Optional) To reset the password or update details, click Manage User(s) > Search all 

users you own.

a. Click Continue twice.

b. Select your account.

c. Click Reset Password to change the password.

d. Click Modify to change any other account details.

Your password changes to the new value that you provided.

6. To access the Avaya Documentation Center dev server, go to https://avaya-8

dev.zoominsoftware.io/.

7. Log in using the credentials that you have created in Step 3 or modified in Step 5.

Next steps

To publish a document on the dev server in Tridion Docs, use the zoomindocs.avaya-staging 

output format.

Setting up Avaya Documentation Center dev account
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Chapter 5: DITA and Content Model 

Trainings

DITA and Content Model Trainings

Training videos provide DITA and content model concepts, and steps to perform key tasks 

involved in creating the content using Tridion Docs and Oxygen XML Author.

Training videos: Content Model and DITA Elements

DITA and Content Model Overview

Video explains DITA and Content Model concepts, and Tools.



Basics of creating a document training video

Training video explains the procedure to create all the components required to create a document.

• Creating folders

• Creating a publication

• Creating maps

• Creating topics

• Adding and editing content in a topic

• Adding maps to a publication

• Adding topics to a publication

• Building a document
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Adding images and tables training video

Training video explains the steps to add and edit images and tables.



Content reuse and content reference training video

Training video covers the steps to reuse the content and add references to content.



Using DITA tags training video

Training video explains the concept of tags and covers the frequently used DITA tags.



Day01 Training videos

Creating a project folder in SDL

To create a document in SDL, create a project folder and the sub folders.



Creating and editing topics

Create a topic object to add content.



Creating and editing DITA maps

Create a Bookmap and DITA maps to map content in a document.



Building a document

Video covers the steps to build a document from start to the end.



Day01 Training videos
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Day02 Training videos

Adding images to content

The video shows the procedure to add images in the content.



Adding tables in the content

Video shows the steps to add a table in the content.



Creating branches and versions

Video describes the scenarios and steps to add branches and versions of an object.



Setting Oxygen XML Author as default editor

Video covers the steps to set Oxygen XML Author as default editor.



DITA and Content Model Trainings
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