Cannot reinstall a non-seed node due to Cassandra startup error

Last Updated : Jun 10, 2026 |

Condition

When reinstalling a non-seed node, Avaya Aura® Device Services becomes unresponsive while trying to start the Cassandra database.

Cause

If the non-seed node was not uninstalled from the cluster properly, then it remains as a registered cluster node in the Cassandra database.

Solution

Procedure

  1. On the non-seed node, run the following command to uninstall the node:
    sudo /opt/Avaya/DeviceServices/<version>/CAS/<version>/uninstaller/uninstallAADS.sh
  2. On the seed node, run the following command to restart services:
    svc aads restart
  3. Reinstall the non-seed node.