Avaya Workplace Soft Clients are logging out due to a mismatch in the ETAG

Last Updated : Jun 10, 2026 |

Condition

Avaya Workplace Soft Clients are logging out due to mismatch in ETAG.

Cause

This issue is due to a lack of ability to copy a settings file around to all Utility servers on AADS with matching modified timestamps for that file down to the nanosecond (9 digits past the decimal point). The copy -p function does not include even milliseconds (3 digits).

Solution

Procedure

If the settings files is copied to Utility servers individually, that same settings file will have different modified timestamps. To ensure that the web server ETags are generated identically for the files, it is important that the file timestamps match to the millisecond across all nodes.

  1. Upload the settings file on the seed node.
  2. Check the timestamp on the seed node using the command line.

    stat -c '%y' 46xxSettings.txt

  3. Copy the same file to the non-seed nodes using a root user (use the -p option (preserve) or --preserve=mode, ownership, timestamps when copying the files)

    scp -p user@<seed node IP>:/var/www/html/custom/46xxSettings.txt user@<non-seed node IP>:/var/www/html/custom/

  4. Compare the timestamps of the file of seed node and non-seed node. If they are different, delete the file from the seed node and copy it back from the non-seed node.

    The timestamps should match now.

    rm 46xxSettings.txt

    scp -p user@<non-seed node IP>:/var/www/html/custom/46xxSettings.txt user@<seed node IP>:/var/www/html/custom/