An agent cannot log in after a failover

Last Updated : Jan 10, 2022 |

Condition

An agent gets logged out after the server failover.

Cause

The agent object in the Shared Memory is not synchronized properly.

Solution

Procedure

  1. Access the active Routing Core Server.
  2. To access the Shared Memory, run the following commands:
    docker exec –it main bash
    ./aicore/state_tools/ss_tester
  3. To view the synchronization connection details, enter x.
  4. Ensure that the synchronization connection is established on Routing Core Server nodes.
  5. In the Agent manager.log file, locate the messages with the login failure cause.

    For example, the error message can be Login - Failed as Station: <endpoint extension> doesn't exist in SHM or Authentication failed, Missing required info for Agent: <agent login ID>.