An agent is logged out after a failover

Last Updated : Jan 10, 2022 |

Condition

You can observe the following:

  • An agent gets logged out after the server failover.

  • The Agent manager.log file displays the tfs_force_logout_timer_expired message for the logged-out agents.

Cause

Time is not synchronized on both nodes.

Solution

Procedure

  1. Access the active Routing Core Server.
  2. To access the Shared Memory, run the following commands:
    docker exec –it main bash
    ./aicore/state_tools/ss_tester
  3. To view the synchronization connection details, enter x.
  4. Check the synchronization connection status for Routing Core Server nodes.
  5. Check if the time is synchronized on the nodes.
  6. If the time is not synchronized, synchronize the nodes.