Mount failure during rollback

Last Updated : May 15, 2023 |

Condition

During rollback, the system displays messages similar to the following example:

         Mounting /tmp
         Mounting /home
. . . 
. . . 
[FAILED] Failed to mount /home.
See 'systemctl status home.mount' for details
. . .
. . .
Welcome to emergency mode! After logging in, type "journalctl -xb" to view
system logs, "systemctl reboot" ro reboot, "systemctl default" or ^D to
try again to boot into default mode.
Give root password for maintenance
(or type Control-D to continue):

Cause

During rollback, the /etc/fstab file was not properly updated and the /home partition was not able to mount.

Solution

Procedure

  1. At the error message prompt, enter the root password.
  2. At the OS prompt, run the following command:

    cat /archive/backup/upgrade/upgrade.conf | grep home

  3. Record the partition number of the /home partition.
  4. Run the following command and check to see if the /home partition number matches what you found in the upgrade.conf file.

    more /etc/fstab

  5. If the partition numbers do not match, edit the /etc/fstab file so that the partition number matches what you found in the upgrade.conf file.
  6. Save and close the file.
  7. Reboot the SBC server.
  8. If this does not fix the problem, contact Avaya support.