Failure to upgrade

Last Updated : Aug 30, 2023 |

Condition

The upgrade scripts include checks for certain conditions which if not matched, cause the upgrade process to stop without performing the upgrade.

Cause

Possible causes of the failure to upgrade are:

  • If the server starts as normal rather than upgrading:

    • The boot source for the upgrade was not the USB upgrade key. Correct the server's boot settings and reattempt the upgrade.

  • If the server automatically shuts down following the upgrade attempt:

    • The system was not running IP Office R11.0.4.8. All upgrades to R11.1.3 must start from R11.0.4.8. When this occurs, the server adds the message "Version found <version> is not 11.0.4.8" to the /logs/backup_logs.txt file.

    • The system shut down using a method other than the Shutdown button shown in its web control menus.

    • Media Manager has run in the past but was not running when the system shut down. The Media Manager server must be running to back up any previous Media Manager settings and data.

Solution

Procedure

  1. Correct the cause of the failure to upgrade above and reattempt the upgrade.
  2. If the upgrade still fails, collect the logs files before raising a support request. See Upgrade logs.