Session Manager cannot connect to a push notification provider

Last Updated : Sep 25, 2020 |

Condition

When you test the connectivity to the push notification server, it fails.

Cause

  • You have configured the notification provider with an incorrect:

    • domain

    • provider address

    • provider port

  • CA certificates not installed in the WebSphere truststore.

  • An authorization key is not generated or a valid JSON formatted key is not present in the Public Settings of your Avaya Cloud account.

Solution

Procedure

  1. Ensure that the enterprise firewall and the push notification provider settings are configured as described in Administering Avaya Aura® Session Manager.
  2. Ensure that the Apple push notification server's public CA certificate is added to the WebSphere truststore.
  3. On the System Manager web console, click Services > Inventory > Manage Elements.
  4. On the Manage Elements page, select one or more elements, and click More Actions > Manage Trusted Certificates.
  5. Click Add.
  6. In the Select Store Type to add trusted certificate field, select WEBSPHERE.
  7. Select Import as PEM certificate.
  8. Locate the PEM certificate.
  9. Open the certificate using Notepad.
  10. Copy the entire contents of the file. You must include the start and end tags: -----BEGIN CERTIFICATE-----" and "-----END CERTIFICATE----.
  11. Paste the contents of the file in the box provided at the bottom of the page.
  12. Click Commit.
  13. Do one of the following:
    • If you are testing the connectivity to the Avaya Push Notification provider, ensure that the authorization data, which you entered in Public Settings on your Avaya Cloud account, is a valid JSON formatted key copied from the Key to Export field of the Provider Settings page.

    • If you are testing the connectivity to a third-party push notification provider, ensure that you correctly entered the system ID and public key information on your push notification provider.

  14. If the problem persists, contact Avaya support.