restartcause

Last Updated : Apr 05, 2018 |

Syntax

restartcause   

Description

Use restartcause to see a list of Communication Manager restarts, their causes, and whether or not each restart escalated into a higher initialization. Use restartcause to help determine when an interchange or reload took place. Restarts are listed in ascending order of time.

Also see display initcauses.

Field

Description

Cause

The reason for the restart.

  • Initialized — System initialization. Internal request = Software requested the restart, usually in response to a server interchange. Internal request restarts are not initiated in direct response to an error and are non-escalating. Software request = Typically, software detected an error and automatically requested a restart.

  • Craft request — A user logged in as craft requested the restart and selected the level through an administration session on the server.

  • Interchange — A State of Health change caused the arbiter process to initiate the restart.

  • Interchange-Craft — An administrative session (session -i command, on-demand interchange) caused the arbiter process to initiate the restart.

  • Internal request — Software requested the restart, usually in response to a server interchange. Internal request restarts are not initiated in direct response to an error and are non-escalating.

  • Software request — Typically, software detected an error and automatically requested a restart.

Action

The level of the restart.

  • 1 (Warm)Communication Manager is restarted. Active calls remain up.

  • 2 (Cold)Communication Manager is restarted, ranslations are preserved, and all calls are dropped.

  • 4 (Reload)Communication Manager software is completely reloaded. All calls are dropped, the translations are reloaded, and the hardware is re-initialized.

Escalated

Escalated indicates whether the current restart has been escalated (increased in level) from a previous level. Restarts can be automatically or manually escalated to a higher level. For example, if the software detected an error and could not resolve the error by doing a level 1 restart, it would automatically initiate a level 2 restart.

Mode

State of the server immediately after the interchange, at the time of the restart. Look for a change of mode to help determine when an interchange occurred.

  • Active — Mode of a simplex server and for a duplex server that is the active server.

  • Standby — Mode of a standby server in a duplex configuration.

  • Busout — Mode of a standby server that has been placed out-of-service with a busyout command.

Time

The date and time the restart occurred. The restarts are displayed in descending order.

Error messages

Error Message

Description

invalid argument: <argument>

More than one arguemnt was entered on the command line.

No initfile at ./initcause.log or /var/log/defty/initcause.log

The data file is either missing or unreadable (for example, there is no read permission).

restartcause: Error reading initcausefile, error — <error>

The command encountered a problem reading the data file. The file is either ./initcause.log or /var/log/defty/initcause.log.