Announcements do not work properly

Last Updated : Jan 10, 2023 |

Condition

Avaya Contact Center – Extended Capacity does not play announcement audio files. The call is not routed to an agent or the caller hears silence or beeps instead of the announcement.

Cause

Audio files are not loaded properly for the following reasons:

  • The audio file format is not correct.

  • The announcement files are not in the Media Server CFG directory.

  • Script Executor did not execute vector steps for the call.

Solution

Procedure

  1. Ensure that the audio files are in the .wav format.
  2. Ensure that the audio files are located in the directory defined in the Media Server directory.

    The default Media Server CFG directory is /data/mbx/sounds/sounds/Tenant/.

  3. Optional If the audio files are missing, on the Configuration Server web portal, upload the files for the corresponding announcements.

    For more information about uploading audio files, see the announcement section in Administering Avaya Contact Center – Extended Capacity.

  4. Review the log files of the following containers for warning messages and errors:
    • Config-backend

    • MinIO

    • TFS

  5. In the Script Engine log files, ensure that the Script Engine executes the vector for the appropriate call.