Endpoints do not register

Last Updated : Dec 16, 2021 |

Condition

Endpoints do not register with the OpenSIPS service.

Cause

The TCP link between an endpoint and the OpenSIPS service is down because the endpoint username or password is incorrect.

Solution

Procedure

  1. Ensure that the endpoint ID and password are correct.
  2. Access the active Routing Core Server.
  3. In the OpenSIPS container, get the tcpdump traces.
  4. Using Wireshark, filter the data with the following parameter:

    tcp.flags.fin=1 || tcp.flags.reset=1

  5. In the filtered data, check if the endpoint or the OpenSIPS service closes the connection.
  6. If the endpoint closes the connection, check the endpoint configuration.

    For more information about the endpoint configuration, see the documentation of endpoints that you use in your contact center.