Cannot answer a call to team or group call pickup button on Avaya Workplace Client for iOS when device is locked

Last Updated : Feb 23, 2024 |

Condition

When iOS suspends Avaya Workplace Client or your device is locked, and you receive a Team button call or Group pickup call, you can see a lock screen notification. To answer the call, you must unlock your device and open Avaya Workplace Client.

Cause

This is a limitation of iOS CallKit and Apple Push Notification service (APNs).

Solution

Unlock your device and open Avaya Workplace Client to answer the call.